CVE-2022-4495

Low

Description

A vulnerability, which was classified as problematic, has been found in collective.dms.basecontent up to 1.6. This issue affects the function renderCell of the file src/collective/dms/basecontent/browser/column.py. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.7 is able to address this issue. The name of the patch is 6c4d616fcc771822a14ebae5e23f3f6d96d134bd. It is recommended to upgrade the affected component. The identifier VDB-215813 was assigned to this vulnerability.

SeverityLow
CVSS3.5
Exploit probability—
ProductCollective.dms.basecontent
PublishedDec 14, 2022
First seenDec 14, 2022

How to fix

Update
  • collective.dms.basecontent_project collective.dms.basecontent1.7 or later
  • collective-dms-basecontent1.7 or later

Affected products

ProductAffected versionsFixed in
collective.dms.basecontent_project collective.dms.basecontentv < 1.71.7
collective-dms-basecontentPyPIv < 1.71.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.