CVE-2022-45064

High

Description

The SlingRequestDispatcher doesn't correctly implement the RequestDispatcher API resulting in a generic type of include-based cross-site scripting issues on the Apache Sling level. The vulnerability is exploitable by an attacker that is able to include a resource with specific content-type and control the include path (i.e. writing content). The impact of a successful attack is privilege escalation to administrative power. Please update to Apache Sling Engine >= 2.14.0 and enable the "Check Content-Type overrides" configuration option.

SeverityHigh
CVSS8.0
Exploit probability66. percentile1.1%
ProductApache Sling Engine
PublishedApr 13, 2023
First seenApr 13, 2023

How to fix

Update
  • apache apache_sling_engine2.14.0 or later
  • org.apache.sling:org.apache.sling.engine2.14.0 or later

Affected products

ProductAffected versionsFixed in
apache apache_sling_enginev < 2.14.02.14.0
org.apache.sling:org.apache.sling.engineMavenv < 2.14.02.14.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.