CVE-2022-45135

Critical

Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Cocoon.This issue affects Apache Cocoon: from 2.2.0 before 2.3.0. Users are recommended to upgrade to version 2.3.0, which fixes the issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Cocoon
PublishedNov 30, 2023
First seenNov 30, 2023
Weakness typeCWE-89SQL injection

How to fix

Update
  • apache cocoon2.3.0 or later
  • org.apache.cocoon:cocoon2.3.0 or later

Affected products

ProductAffected versionsFixed in
apache cocoon2.2.0 ≤ v < 2.3.02.3.0
org.apache.cocoon:cocoonMaven2.2.0 ≤ v < 2.3.02.3.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.