CVE-2022-4524

Low

Description

A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.

SeverityLow
CVSS3.5
Exploit probability—
ProductRoots Soil
PublishedDec 15, 2022
First seenDec 15, 2022

How to fix

Update
  • roots soil4.1.0 or later
  • roots/soil4.1.0 or later

Affected products

ProductAffected versionsFixed in
roots soilv < 4.1.04.1.0
roots/soilPackagistv < 4.1.04.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.