CVE-2022-45589
High
Description
All versions before 8.0.1-R2022-10-RT and 7.3.1-R2022-09-RT of the Talend ESB Runtime are potentially vulnerable to SQL Injection attacks in the provisioning service only. Users of the provisioning service should upgrade to either 8.0.1-R2022-10-RT or 7.3.1-R2022-09-RT or a later release and use it in place of the previous version.
SeverityHigh
CVSS7.2
Exploit probability—
ProductTalend Esb Runtime
PublishedFeb 6, 2023
First seenFeb 6, 2023
Weakness typeCWE-89SQL injection
How to fix
Update
- talend esb_runtime7.3.1-r2022-09-rt, 8.0.1-r2022-10-rt or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| talend esb_runtime | v < 7.3.1-r2022-09-rt, 8.0 ≤ v < 8.0.1-r2022-10-rt | 7.3.1-r2022-09-rt, 8.0.1-r2022-10-rt |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.