CVE-2022-45855
High
Description
SpringEL injection in the metrics source in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.
SeverityHigh
CVSS8.0
Exploit probability—
Product
Apache Ambari
PublishedJul 12, 2023
First seenJul 12, 2023
Weakness typeCWE-917Expression language injection
How to fix
Update
- apache ambari2.7.7 or later
- org.apache.ambari:ambari2.7.7 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache ambari | 2.7.0 ≤ v < 2.7.7 | 2.7.7 |
| org.apache.ambari:ambariMaven | 2.7.0 ≤ v < 2.7.7 | 2.7.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.