CVE-2022-46170

High

Description

CodeIgniter is a PHP full-stack web framework. When an application uses (1) multiple session cookies (e.g., one for user pages and one for admin pages) and (2) a session handler is set to `DatabaseHandler`, `MemcachedHandler`, or `RedisHandler`, then if an attacker gets one session cookie (e.g., one for user pages), they may be able to access pages that require another session cookie (e.g., for admin pages). This issue has been patched, please upgrade to version 4.2.11 or later. As a workaround, use only one session cookie.

SeverityHigh
CVSS8.6
Exploit probability—
ProductCodeigniter
PublishedDec 22, 2022
First seenDec 22, 2022

How to fix

Update
  • codeigniter codeigniter4.2.11 or later
  • codeigniter4/framework4.2.11 or later

Affected products

ProductAffected versionsFixed in
codeigniter codeigniter4.0.0 ≤ v < 4.2.114.2.11
codeigniter4/frameworkPackagistv < 4.2.114.2.11

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2022-46170 · Codeigniter · Dark Radar