CVE-2022-46256
Description
A path traversal vulnerability was identified in GitHub Enterprise Server that allowed remote code execution when building a GitHub Pages site. To exploit this vulnerability, an attacker would need permission to create and build a GitHub Pages site on the instance. This vulnerability was fixed in versions 3.3.17, 3.4.12, 3.5.9, 3.6.5 and 3.7.2. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- github enterprise_server3.3.17, 3.4.12, 3.5.9, 3.6.5, 3.7.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | v < 3.3.17, 3.4.0 ≤ v < 3.4.12, 3.5.0 ≤ v < 3.5.9, 3.6.0 ≤ v < 3.6.5, 3.7.0 ≤ v < 3.7.2 | 3.3.17, 3.4.12, 3.5.9, 3.6.5, 3.7.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.