CVE-2022-46258

Medium

Description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a repository-scoped token with read/write access to modify Action Workflow files without a Workflow scope. The Create or Update file contents API should enforce workflow scope. This vulnerability affected all versions of GitHub Enterprise Server prior to version 3.7 and was fixed in versions 3.3.16, 3.4.11, 3.5.8, and 3.6.4. This vulnerability was reported via the GitHub Bug Bounty program.

SeverityMedium
CVSS6.5
Exploit probability—
ProductGithub Enterprise Server
PublishedJan 9, 2023
First seenJan 9, 2023

How to fix

Update
  • github enterprise_server3.3.16, 3.4.11, 3.5.8, 3.6.4 or later

Affected products

ProductAffected versionsFixed in
github enterprise_serverv < 3.3.16, 3.4.0 ≤ v < 3.4.11, 3.5.0 ≤ v < 3.5.8, 3.6.0 ≤ v < 3.6.43.3.16, 3.4.11, 3.5.8, 3.6.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.