CVE-2022-46337

Critical

Description

A cleverly devised username might bypass LDAP authentication checks. In LDAP-authenticated Derby installations, this could let an attacker fill up the disk by creating junk Derby databases. In LDAP-authenticated Derby installations, this could also allow the attacker to execute malware which was visible to and executable by the account which booted the Derby server. In LDAP-protected databases which weren't also protected by SQL GRANT/REVOKE authorization, this vulnerability could also let an attacker view and corrupt sensitive data and run sensitive database functions and procedures. Mitigation: Users should upgrade to Java 21 and Derby 10.17.1.0. Alternatively, users who wish to remain on older Java versions should build their own Derby distribution from one of the release families to which the fix was backported: 10.16, 10.15, and 10.14. Those are the releases which correspond, respectively, with Java LTS versions 17, 11, and 8.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Derby
PublishedNov 20, 2023
First seenNov 20, 2023
Weakness typeCWE-74Injection

How to fix

Update
  • apache derby10.14.3.0, 10.15.2.1 or later
  • org.apache.derby:derby10.14.2.1, 10.16.1.2, 10.15.2.1 or later

Affected products

ProductAffected versionsFixed in
apache derby10.1.1.0 ≤ v < 10.14.3.0, 10.15.1.3 ≤ v < 10.15.2.1, 10.16.1.110.14.3.0, 10.15.2.1
org.apache.derby:derbyMaven10.1.1.0 ≤ v ≤ 10.1.3.1, 10.2.1.6 ≤ v ≤ 10.2.2.0, 10.3.1.4 ≤ v ≤ 10.3.3.0, 10.4.1.3 ≤ v ≤ 10.4.2.0, 10.5.1.1 ≤ v ≤ 10.5.3.0, 10.6.1.0 ≤ v ≤ 10.6.2.1, No range specified, 10.8.1.2 ≤ v ≤ 10.8.3.0, 10.10.1.1 ≤ v ≤ 10.10.2.0, 10.14.2.0 ≤ v < 10.14.2.1, 10.16.1.1 ≤ v < 10.16.1.2, 10.15.1.3 ≤ v < 10.15.2.110.14.2.1, 10.16.1.2, 10.15.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.