CVE-2022-4643
Description
A vulnerability was found in docconv up to 1.2.0. It has been declared as critical. This vulnerability affects the function ConvertPDFImages of the file pdf_ocr.go. The manipulation of the argument path leads to os command injection. The attack can be initiated remotely. Upgrading to version 1.2.1 is able to address this issue. The name of the patch is b19021ade3d0b71c89d35cb00eb9e589a121faa5. It is recommended to upgrade the affected component. VDB-216502 is the identifier assigned to this vulnerability.
How to fix
- search docconv1.2.1 or later
- github.com/sajari/docconv1.2.1 or later
- code.sajari.com/docconv1.3.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| search docconv | v < 1.2.1 | 1.2.1 |
| github.com/sajari/docconvGo | v < 1.2.1 | 1.2.1 |
| code.sajari.com/docconvGo | 1.1.0 ≤ v < 1.3.5 | 1.3.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.