CVE-2022-46651

Medium

Description

Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an unauthorized actor to gain access to sensitive information in Connection edit view. This vulnerability is considered low since it requires someone with access to Connection resources specifically updating the connection to exploit it. Users should upgrade to version 2.6.3 or later which has removed the vulnerability.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Airflow
PublishedJul 12, 2023
First seenJul 12, 2023

How to fix

Update
  • apache airflow2.6.3 or later
  • apache-airflow2.6.3 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.6.32.6.3
apache-airflowPyPIv < 2.6.32.6.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.