CVE-2022-46792

High

Description

Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends. The fixed versions are 2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, and 2.15.2. (Versions before 2.10.0 are unaffected.)

SeverityHigh
CVSS8.8
Exploit probability—
ProductHasura Graphql Engine
PublishedDec 8, 2022
First seenDec 8, 2022

How to fix

Update
  • hasura graphql_engine2.10.2, 2.11.3, 2.13.2, 2.15.2 or later

Affected products

ProductAffected versionsFixed in
hasura graphql_engine2.10.0 ≤ v < 2.10.2, 2.11.0 ≤ v < 2.11.3, 2.13.0 ≤ v < 2.13.2, 2.15.0 ≤ v < 2.15.2, 2.12.0, 2.14.02.10.2, 2.11.3, 2.13.2, 2.15.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.