CVE-2022-46907

Medium

Description

A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.

SeverityMedium
CVSS6.1
Exploit probability—
ProductApache Jspwiki
PublishedMay 25, 2023
First seenMay 25, 2023

How to fix

Update
  • apache jspwiki2.12.0 or later
  • org.apache.jspwiki:jspwiki-main2.12.0 or later
  • org.apache.jspwiki:jspwiki-war2.12.0 or later

Affected products

ProductAffected versionsFixed in
apache jspwikiv < 2.12.02.12.0
org.apache.jspwiki:jspwiki-mainMavenv < 2.12.02.12.0
org.apache.jspwiki:jspwiki-warMavenv < 2.12.02.12.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.