CVE-2022-4957

Low

Description

A vulnerability was found in librespeed speedtest up to 5.2.4. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file results/stats.php. The manipulation of the argument id leads to cross site scripting. The attack can be launched remotely. Upgrading to version 5.2.5 is able to address this issue. The patch is named a85f2c086f3449dffa8fe2edb5e2ef3ee72dc0e9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-246643.

SeverityLow
CVSS3.5
Exploit probability—
ProductLibrespeed Speedtest
PublishedDec 3, 2023
First seenDec 3, 2023

How to fix

Affected products

ProductAffected versionsFixed in
librespeed speedtestv ≤ 5.2.4—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.