CVE-2023-0109

Medium

Description

A stored cross-site scripting (XSS) vulnerability was discovered in usememos/memos version 0.9.1. This vulnerability allows an attacker to upload a JavaScript file containing a malicious script and reference it in an HTML file. When the HTML file is accessed, the malicious script is executed. This can lead to the theft of sensitive information, such as login credentials, from users visiting the affected website. The issue has been fixed in version 0.10.0.

SeverityMedium
CVSS5.4
Exploit probability—
ProductMemos
PublishedNov 15, 2024
First seenNov 15, 2024

How to fix

Update
  • github.com/usememos/memos0.10.0 or later

Affected products

ProductAffected versionsFixed in
usememos memos0.9.1—
github.com/usememos/memosGov < 0.10.00.10.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.