CVE-2023-0507
Description
Grafana is an open-source platform for monitoring and observability. Starting with the 8.1 branch, Grafana had a stored XSS vulnerability affecting the core plugin GeoMap. The stored XSS vulnerability was possible due to map attributions weren't properly sanitized and allowed arbitrary JavaScript to be executed in the context of the currently authorized user of the Grafana instance. An attacker needs to have the Editor role in order to change a panel to include a map attribution containing JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. Users may upgrade to version 8.5.21, 9.2.13 and 9.3.8 to receive a fix.
How to fix
- grafana grafana8.5.21, 9.2.13, 9.3.8 or later
- github.com/grafana/grafana8.5.21, 9.2.13, 9.3.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| grafana grafana | 8.1.0 ≤ v < 8.5.21, 9.2.0 ≤ v < 9.2.13, 9.3.0 ≤ v < 9.3.8 | 8.5.21, 9.2.13, 9.3.8 |
| github.com/grafana/grafanaGo | 8.1.0 ≤ v < 8.5.21, 9.0.0 ≤ v < 9.2.13, 9.3.0 ≤ v < 9.3.8 | 8.5.21, 9.2.13, 9.3.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.