CVE-2023-0620
Description
HashiCorp Vault and Vault Enterprise versions 0.8.0 through 1.13.1 are vulnerable to an SQL injection attack when configuring the Microsoft SQL (MSSQL) Database Storage Backend. When configuring the MSSQL plugin through the local, certain parameters are not sanitized when passed to the user-provided MSSQL database. An attacker may modify these parameters to execute a malicious SQL command. This issue is fixed in versions 1.13.1, 1.12.5, and 1.11.9.
How to fix
- hashicorp vault1.11.9, 1.12.5, 1.13.1 or later
- github.com/hashicorp/vault1.11.9, 1.12.5, 1.13.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| hashicorp vault | v < 1.11.9, 1.12.0 ≤ v < 1.12.5, 1.13.0 ≤ v < 1.13.1 | 1.11.9, 1.12.5, 1.13.1 |
| github.com/hashicorp/vaultGo | 0.8.0 ≤ v < 1.11.9, 1.12.0 ≤ v < 1.12.5, 1.13.0 ≤ v < 1.13.1 | 1.11.9, 1.12.5, 1.13.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.