CVE-2023-0815

Medium

Description

Potential Insertion of Sensitive Information into Jetty Log Files in multiple versions of OpenNMS Meridian and Horizon could allow disclosure of usernames and passwords if the logging level is set to debug. Users should upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

SeverityMedium
CVSS6.8
Exploit probability—
ProductOpennms Horizon
PublishedFeb 23, 2023
First seenFeb 23, 2023
Weakness typeCWE-532CWE-532

How to fix

Update
  • opennms horizon31.0.4 or later
  • opennms meridian2023.1.0 or later
  • org.opennms:opennms31.0.4 or later

Affected products

ProductAffected versionsFixed in
opennms horizonv < 31.0.431.0.4
opennms meridianv < 2023.1.02023.1.0
org.opennms:opennmsMavenv < 31.0.431.0.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.