CVE-2023-0868

Medium

Description

Reflected cross-site scripting in graph results in multiple versions of OpenNMS Meridian and Horizon could allow an attacker access to steal session cookies. Users should upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

SeverityMedium
CVSS6.7
Exploit probability—
ProductOpennms Horizon
PublishedFeb 23, 2023
First seenFeb 23, 2023

How to fix

Update
  • opennms horizon31.0.4 or later
  • opennms meridian2023.1.0 or later
  • org.opennms:opennms-webapp31.0.4 or later

Affected products

ProductAffected versionsFixed in
opennms horizonv < 31.0.431.0.4
opennms meridianv < 2023.1.02023.1.0
org.opennms:opennms-webappMavenv < 31.0.431.0.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.