CVE-2023-0869
Description
Cross-site scripting in outage/list.htm in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
How to fix
- opennms horizon31.0.4 or later
- opennms meridian2023.1.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| opennms horizon | v < 31.0.4 | 31.0.4 |
| opennms meridian | v < 2023.1.0 | 2023.1.0 |
| org.opennms:opennms-web-apiMaven | v ≤ 31.0.3 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.