CVE-2023-0872
Description
The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.
How to fix
- opennms horizon32.0.2 or later
- org.opennms:opennms-webapp-rest32.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| opennms horizon | 31.0.8 ≤ v < 32.0.2 | 32.0.2 |
| opennms meridian | 2020.0.0 ≤ v ≤ 2020.1.37, 2021.0.0 ≤ v ≤ 2021.1.29, 2022.0.0 ≤ v ≤ 2022.1.18, 2023.0.0 ≤ v ≤ 2023.1.5 | — |
| org.opennms:opennms-webapp-restMaven | 31.0.8 ≤ v < 32.0.2 | 32.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.