CVE-2023-2017
Description
Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in `Shopware\Core\Framework\Adapter\Twig\SecurityExtension` and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.
How to fix
- shopware/platform6.4.20.1 or later
- shopware/core6.4.20.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| shopware shopware | 6.1.0 ≤ v ≤ 6.4.20.0, 6.5.0.0 | — |
| shopware/platformPackagist | v < 6.4.20.1 | 6.4.20.1 |
| shopware/corePackagist | v < 6.4.20.1 | 6.4.20.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.