CVE-2023-22381
Description
A code injection vulnerability was identified in GitHub Enterprise Server that allowed setting arbitrary environment variables from a single environment variable value in GitHub Actions when using a Windows based runner. To exploit this vulnerability, an attacker would need existing permission to control the value of environment variables for use with GitHub Actions. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.8.0 and was fixed in versions 3.4.15, 3.5.12, 3.6.8, 3.7.5. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- github enterprise_server3.4.15, 3.5.12, 3.6.8, 3.7.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | v < 3.4.15, 3.5.0 ≤ v < 3.5.12, 3.6.0 ≤ v < 3.6.8, 3.7.0 ≤ v < 3.7.5 | 3.4.15, 3.5.12, 3.6.8, 3.7.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.