CVE-2023-22457

Critical

Description

CKEditor Integration UI adds support for editing wiki pages using CKEditor. Prior to versions 1.64.3,t he `CKEditor.HTMLConverter` document lacked a protection against Cross-Site Request Forgery (CSRF), allowing to execute macros with the rights of the current user. If a privileged user with programming rights was tricked into executing a GET request to this document with certain parameters (e.g., via an image with a corresponding URL embedded in a comment or via a redirect), this would allow arbitrary remote code execution and the attacker could gain rights, access private information or impact the availability of the wiki. The issue has been patched in the CKEditor Integration version 1.64.3. This has also been patched in the version of the CKEditor integration that is bundled starting with XWiki 14.6 RC1. There are no known workarounds for this other than upgrading the CKEditor integration to a fixed version.

SeverityCritical
CVSS9.0
Exploit probability—
ProductXwiki Ckeditor Integration
PublishedJan 4, 2023
First seenJan 4, 2023

How to fix

Update
  • xwiki ckeditor_integration1.64.3 or later
  • org.xwiki.contrib:application-ckeditor-ui1.64.3 or later

Affected products

ProductAffected versionsFixed in
xwiki ckeditor_integrationv < 1.64.31.64.3
org.xwiki.contrib:application-ckeditor-uiMavenv < 1.64.31.64.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.