CVE-2023-22513
Description
This High severity RCE (Remote Code Execution) vulnerability was introduced in version 8.0.0 of Bitbucket Data Center and Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8.5, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires no user interaction. Atlassian recommends that Bitbucket Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Bitbucket Data Center and Server 8.9: Upgrade to a release greater than or equal to 8.9.5 Bitbucket Data Center and Server 8.10: Upgrade to a release greater than or equal to 8.10.5 Bitbucket Data Center and Server 8.11: Upgrade to a release greater than or equal to 8.11.4 Bitbucket Data Center and Server 8.12: Upgrade to a release greater than or equal to 8.12.2 Bitbucket Data Center and Server 8.13: Upgrade to a release greater than or equal to 8.13.1 Bitbucket Data Center and Server 8.14: Upgrade to a release greater than or equal to 8.14.0 Bitbucket Data Center and Server version >= 8.0 and < 8.9: Upgrade to any of the listed fix versions. See the release notes (https://confluence.atlassian.com/bitbucketserver/release-notes). You can download the latest version of Bitbucket Data Center and Server from the download center (https://www.atlassian.com/software/bitbucket/download-archives). This vulnerability was discovered by a private user and reported via our Bug Bounty program
How to fix
- atlassian bitbucket_data_center8.9.5, 8.10.5, 8.11.4, 8.12.2 or later
- atlassian bitbucket_server8.9.5, 8.10.5, 8.11.4, 8.12.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| atlassian bitbucket_data_center | 8.9.0 ≤ v < 8.9.5, 8.10.0 ≤ v < 8.10.5, 8.11.0 ≤ v < 8.11.4, 8.12.0 ≤ v < 8.12.2, 8.13.0 | 8.9.5, 8.10.5, 8.11.4, 8.12.2 |
| atlassian bitbucket_server | 8.9.0 ≤ v < 8.9.5, 8.10.0 ≤ v < 8.10.5, 8.11.0 ≤ v < 8.11.4, 8.12.0 ≤ v < 8.12.2, 8.13.0 | 8.9.5, 8.10.5, 8.11.4, 8.12.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.