CVE-2023-22727
Description
CakePHP is a development framework for PHP web apps. In affected versions the `Cake\Database\Query::limit()` and `Cake\Database\Query::offset()` methods are vulnerable to SQL injection if passed un-sanitized user request data. This issue has been fixed in 4.2.12, 4.3.11, 4.4.10. Users are advised to upgrade. Users unable to upgrade may mitigate this issue by using CakePHP's Pagination library. Manually validating or casting parameters to these methods will also mitigate the issue.
How to fix
- cakephp cakephp4.2.12, 4.3.11, 4.4.10 or later
- cakephp/cakephp4.2.12, 4.3.11, 4.4.10 or later
- cakephp/database4.2.12, 4.3.11, 4.4.10 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| cakephp cakephp | 4.2.0 ≤ v < 4.2.12, 4.3.0 ≤ v < 4.3.11, 4.4.0 ≤ v < 4.4.10 | 4.2.12, 4.3.11, 4.4.10 |
| cakephp/cakephpPackagist | 4.2.0 ≤ v < 4.2.12, 4.3.0 ≤ v < 4.3.11, 4.4.0 ≤ v < 4.4.10 | 4.2.12, 4.3.11, 4.4.10 |
| cakephp/databasePackagist | 4.2.0 ≤ v < 4.2.12, 4.3.0 ≤ v < 4.3.11, 4.4.0 ≤ v < 4.4.10 | 4.2.12, 4.3.11, 4.4.10 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.