CVE-2023-22731

Critical

Description

Shopware is an open source commerce platform based on Symfony Framework and Vue js. In a Twig environment **without the Sandbox extension**, it is possible to refer to PHP functions in twig filters like `map`, `filter`, `sort`. This allows a template to call any global PHP function and thus execute arbitrary code. The attacker must have access to a Twig environment in order to exploit this vulnerability. This problem has been fixed with 6.4.18.1 with an override of the specified filters until the integration of the Sandbox extension has been finished. Users are advised to upgrade. Users of major versions 6.1, 6.2, and 6.3 may also receive this fix via a plugin.

SeverityCritical
CVSS9.9
Exploit probability—
ProductShopware
PublishedJan 17, 2023
First seenJan 17, 2023

How to fix

Update
  • shopware shopware6.4.18.1 or later
  • shopware/platform6.4.18.1 or later
  • shopware/core6.4.18.1 or later

Affected products

ProductAffected versionsFixed in
shopware shopwarev < 6.4.18.16.4.18.1
shopware/platformPackagistv < 6.4.18.16.4.18.1
shopware/corePackagistv < 6.4.18.16.4.18.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.