CVE-2023-2279

Medium

Description

The WP Directory Kit plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.2.1. This is due to missing or incorrect nonce validation on the 'admin_page_display' function. This makes it possible for unauthenticated attackers to delete or change plugin settings, import demo data, modify or delete Directory Kit related posts and terms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Partial patches were made avilable in versions 1.2.0 and 1.2.1 but the issue was not fully patched until 1.2.2

SeverityMedium
CVSS5.4
Exploit probability—
ProductWpdirectorykit Wp Directory Kit
PublishedAug 31, 2023
First seenAug 31, 2023

How to fix

Update
  • wpdirectorykit wp_directory_kit1.2.2 or later

Affected products

ProductAffected versionsFixed in
wpdirectorykit wp_directory_kitv < 1.2.21.2.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.