CVE-2023-22835
High
Description
A security defect was identified that enabled a user of Foundry Issues to perform a Denial of Service attack by submitting malformed data in an Issue that caused loss of frontend functionality to all issue participants. This defect was resolved with the release of Foundry Issues 2.510.0 and Foundry Frontend 6.228.0.
SeverityHigh
CVSS7.7
Exploit probability—
ProductPalantir Foundry Frontend
PublishedJul 10, 2023
First seenJul 10, 2023
Weakness typeCWE-20Improper input validation
How to fix
Update
- palantir foundry_frontend6.228.0 or later
- palantir foundry_issues2.510.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| palantir foundry_frontend | v < 6.228.0 | 6.228.0 |
| palantir foundry_issues | v < 2.510.0 | 2.510.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.