CVE-2023-23612
Description
OpenSearch is an open source distributed and RESTful search engine. OpenSearch uses JWTs to store role claims obtained from the Identity Provider (IdP) when the authentication backend is SAML or OpenID Connect. There is an issue in how those claims are processed from the JWTs where the leading and trailing whitespace is trimmed, allowing users to potentially claim roles they are not assigned to if any role matches the whitespace-stripped version of the roles they are a member of. This issue is only present for authenticated users, and it requires either the existence of roles that match, not considering leading/trailing whitespace, or the ability for users to create said matching roles. In addition, the Identity Provider must allow leading and trailing spaces in role names. OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 are affected. Users are advised to upgrade to OpenSearch 1.3.8 or 2.5.0. There are no known workarounds for this issue.
How to fix
- amazon opensearch1.3.8, 2.5.0 or later
- org.opensearch.plugin:opensearch-security1.3.8, 2.5.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| amazon opensearch | 1.0.0 ≤ v < 1.3.8, 2.0.0 ≤ v < 2.5.0 | 1.3.8, 2.5.0 |
| org.opensearch.plugin:opensearch-securityMaven | v < 1.3.8, 2.0.0 ≤ v < 2.5.0 | 1.3.8, 2.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.