CVE-2023-23613
Description
OpenSearch is an open source distributed and RESTful search engine. In affected versions there is an issue in the implementation of field-level security (FLS) and field masking where rules written to explicitly exclude fields are not correctly applied for certain queries that rely on their auto-generated .keyword fields. This issue is only present for authenticated users with read access to the indexes containing the restricted fields. This may expose data which may otherwise not be accessible to the user. OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 are affected. Users are advised to upgrade to OpenSearch 1.3.8 or 2.5.0. Users unable to upgrade may write explicit exclusion rules as a workaround. Policies authored in this way are not subject to this issue.
How to fix
- amazon opensearch1.3.8, 2.5.0 or later
- org.opensearch.plugin:opensearch-security1.3.8, 2.5.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| amazon opensearch | 1.0.0 ≤ v < 1.3.8, 2.0.0 ≤ v < 2.5.0 | 1.3.8, 2.5.0 |
| org.opensearch.plugin:opensearch-securityMaven | v < 1.3.8, 2.0.0 ≤ v < 2.5.0 | 1.3.8, 2.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.