CVE-2023-23761
Description
An improper authentication vulnerability was identified in GitHub Enterprise Server that allowed an unauthorized actor to modify other users' secret gists by authenticating through an SSH certificate authority. To do so, a user had to know the secret gist's URL. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.9 and was fixed in versions 3.4.18, 3.5.15, 3.6.11, 3.7.8, and 3.8.1. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- github enterprise_server3.4.18, 3.5.15, 3.6.11, 3.7.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | v < 3.4.18, 3.5.0 ≤ v < 3.5.15, 3.6.0 ≤ v < 3.6.11, 3.7.0 ≤ v < 3.7.8, 3.8.0 | 3.4.18, 3.5.15, 3.6.11, 3.7.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.