CVE-2023-23762

Medium

Description

An incorrect comparison vulnerability was identified in GitHub Enterprise Server that allowed commit smuggling by displaying an incorrect diff. To do so, an attacker would need write access to the repository and be able to correctly guess the target branch before it’s created by the code maintainer. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.9 and was fixed in versions 3.4.18, 3.5.15, 3.6.11, 3.7.8, and 3.8.1. This vulnerability was reported via the GitHub Bug Bounty program.

SeverityMedium
CVSS6.5
Exploit probability—
ProductGithub Enterprise Server
PublishedApr 7, 2023
First seenApr 7, 2023
Weakness typeCWE-697CWE-697

How to fix

Update
  • github enterprise_server3.4.18, 3.5.15, 3.6.11, 3.7.8 or later

Affected products

ProductAffected versionsFixed in
github enterprise_serverv < 3.4.18, 3.5.0 ≤ v < 3.5.15, 3.6.0 ≤ v < 3.6.11, 3.7.0 ≤ v < 3.7.8, 3.8.03.4.18, 3.5.15, 3.6.11, 3.7.8

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.