CVE-2023-23936
Medium
Description
Undici is an HTTP/1.1 client for Node.js. Starting with version 2.0.0 and prior to version 5.19.1, the undici library does not protect `host` HTTP header from CRLF injection vulnerabilities. This issue is patched in Undici v5.19.1. As a workaround, sanitize the `headers.host` string before passing to undici.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Nodejs Node.js
PublishedFeb 16, 2023
First seenFeb 16, 2023
Weakness typeCWE-93CWE-93
How to fix
Update
- nodejs node.js16.19.1, 18.14.1, 19.6.1 or later
- nodejs undici5.19.1 or later
- undici5.19.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nodejs node.js | 16.0.0 ≤ v < 16.19.1, 18.0.0 ≤ v < 18.14.1, 19.0.0 ≤ v < 19.6.1 | 16.19.1, 18.14.1, 19.6.1 |
| nodejs undici | 2.0.0 ≤ v < 5.19.1 | 5.19.1 |
| undicinpm | 2.0.0 ≤ v < 5.19.1 | 5.19.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.