CVE-2023-25153

Medium

Description

containerd is an open source container runtime. Before versions 1.6.18 and 1.5.18, when importing an OCI image, there was no limit on the number of bytes read for certain files. A maliciously crafted image with a large file where a limit was not applied could cause a denial of service. This bug has been fixed in containerd 1.6.18 and 1.5.18. Users should update to these versions to resolve the issue. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.

SeverityMedium
CVSS6.2
Exploit probability—
ProductLinuxfoundation Containerd
PublishedFeb 16, 2023
First seenFeb 16, 2023

How to fix

Update
  • linuxfoundation containerd1.5.18, 1.6.18 or later
  • github.com/containerd/containerd1.5.18, 1.6.18 or later

Affected products

ProductAffected versionsFixed in
linuxfoundation containerdv < 1.5.18, 1.6.0 ≤ v < 1.6.181.5.18, 1.6.18
github.com/containerd/containerdGov < 1.5.18, 1.6.0 ≤ v < 1.6.181.5.18, 1.6.18

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.