CVE-2023-25157

Critical

Description

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. GeoServer includes support for the OGC Filter expression language and the OGC Common Query Language (CQL) as part of the Web Feature Service (WFS) and Web Map Service (WMS) protocols. CQL is also supported through the Web Coverage Service (WCS) protocol for ImageMosaic coverages. Users are advised to upgrade to either version 2.21.4, or version 2.22.2 to resolve this issue. Users unable to upgrade should disable the PostGIS Datastore *encode functions* setting to mitigate ``strEndsWith``, ``strStartsWith`` and ``PropertyIsLike `` misuse and enable the PostGIS DataStore *preparedStatements* setting to mitigate the ``FeatureId`` misuse.

SeverityCritical
CVSS9.8
Exploit probability—
ProductOsgeo Geoserver
PublishedFeb 21, 2023
First seenFeb 21, 2023
Weakness typeCWE-89SQL injection

How to fix

Update
  • osgeo geoserver2.18.7, 2.19.7, 2.20.7, 2.21.4, 2.22.2 or later
  • org.geoserver.community:gs-jdbcconfig2.21.4, 2.22.2 or later

Affected products

ProductAffected versionsFixed in
osgeo geoserverv < 2.18.7, 2.19.0 ≤ v < 2.19.7, 2.20.0 ≤ v < 2.20.7, 2.21.0 ≤ v < 2.21.4, 2.22.0 ≤ v < 2.22.22.18.7, 2.19.7, 2.20.7, 2.21.4, 2.22.2
org.geoserver.community:gs-jdbcconfigMavenv < 2.21.4, 2.22.0 ≤ v < 2.22.22.21.4, 2.22.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.