CVE-2023-25168
Description
Wings is Pterodactyl's server control plane. This vulnerability can be used to delete files and directories recursively on the host system. This vulnerability can be combined with `GHSA-p8r3-83r8-jwj5` to overwrite files on the host system. In order to use this exploit, an attacker must have an existing "server" allocated and controlled by Wings. This vulnerability has been resolved in version `v1.11.4` of Wings, and has been back-ported to the 1.7 release series in `v1.7.4`. Anyone running `v1.11.x` should upgrade to `v1.11.4` and anyone running `v1.7.x` should upgrade to `v1.7.4`. There are no known workarounds for this issue.
How to fix
- pterodactyl wings1.7.4 or later
- github.com/pterodactyl/wings1.7.4, 1.11.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| pterodactyl wings | 1.7.0 ≤ v < 1.7.4, 1.11.0, 1.11.1, 1.11.2, 1.11.3 | 1.7.4 |
| github.com/pterodactyl/wingsGo | v < 1.7.4, 1.11.0 ≤ v < 1.11.4 | 1.7.4, 1.11.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.