CVE-2023-25172

Medium

Description

Discourse is an open-source discussion platform. Prior to version 3.0.1 of the `stable` branch and version 3.1.0.beta2 of the `beta` and `tests-passed` branches, a maliciously crafted URL can be included in a user's full name field to to carry out cross-site scripting attacks on sites with a disabled or overly permissive CSP (Content Security Policy). Discourse's default CSP prevents this vulnerability. The vulnerability is patched in version 3.0.1 of the `stable` branch and version 3.1.0.beta2 of the `beta` and `tests-passed` branches. As a workaround, enable and/or restore your site's CSP to the default one provided with Discourse.

SeverityMedium
CVSS4.4
Exploit probability—
ProductDiscourse
PublishedMar 17, 2023
First seenMar 17, 2023

How to fix

Update
  • discourse discourse3.0.1, 3.1.0 or later

Affected products

ProductAffected versionsFixed in
discourse discoursev < 3.0.1, v < 3.1.0, 3.1.03.0.1, 3.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.