CVE-2023-25173

Medium

Description

containerd is an open source container runtime. A bug was found in containerd prior to versions 1.6.18 and 1.5.18 where supplementary groups are not set up properly inside a container. If an attacker has direct access to a container and manipulates their supplementary group access, they may be able to use supplementary group access to bypass primary group restrictions in some cases, potentially gaining access to sensitive information or gaining the ability to execute code in that container. Downstream applications that use the containerd client library may be affected as well. This bug has been fixed in containerd v1.6.18 and v.1.5.18. Users should update to these versions and recreate containers to resolve this issue. Users who rely on a downstream application that uses containerd's client library should check that application for a separate advisory and instructions. As a workaround, ensure that the `"USER $USERNAME"` Dockerfile instruction is not used. Instead, set the container entrypoint to a value similar to `ENTRYPOINT ["su", "-", "user"]` to allow `su` to properly set up supplementary groups.

SeverityMedium
CVSS5.3
Exploit probability—
ProductLinuxfoundation Containerd
PublishedFeb 16, 2023
First seenFeb 16, 2023

How to fix

Update
  • linuxfoundation containerd1.5.18, 1.6.18 or later
  • github.com/containerd/containerd1.5.18, 1.6.18 or later

Affected products

ProductAffected versionsFixed in
linuxfoundation containerdv < 1.5.18, 1.6.0 ≤ v < 1.6.181.5.18, 1.6.18
github.com/containerd/containerdGov < 1.5.18, 1.6.0 ≤ v < 1.6.181.5.18, 1.6.18

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-25173 · Linuxfoundation Containerd · Dark Radar