CVE-2023-25565

High

Description

GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, an incorrect free when decoding target information can trigger a denial of service. The error condition incorrectly assumes the `cb` and `sh` buffers contain a copy of the data that needs to be freed. However, that is not the case. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This will likely trigger an assertion failure in `free`, causing a denial-of-service. This issue is fixed in version 1.2.0.

SeverityHigh
CVSS7.5
Exploit probability—
ProductGss-ntlmssp
PublishedFeb 14, 2023
First seenFeb 14, 2023
Weakness typeCWE-590CWE-590

How to fix

Update
  • gss-ntlmssp_project gss-ntlmssp1.2.0 or later

Affected products

ProductAffected versionsFixed in
gss-ntlmssp_project gss-ntlmsspv < 1.2.01.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.