CVE-2023-25567

High

Description

GSS-NTLMSSP, a mechglue plugin for the GSSAPI library that implements NTLM authentication, has an out-of-bounds read when decoding target information prior to version 1.2.0. The length of the `av_pair` is not checked properly for two of the elements which can trigger an out-of-bound read. The out-of-bounds read can be triggered via the main `gss_accept_sec_context` entry point and could cause a denial-of-service if the memory is unmapped. The issue is fixed in version 1.2.0.

SeverityHigh
CVSS7.5
Exploit probability—
ProductGss-ntlmssp
PublishedFeb 14, 2023
First seenFeb 14, 2023

How to fix

Update
  • gss-ntlmssp_project gss-ntlmssp1.2.0 or later

Affected products

ProductAffected versionsFixed in
gss-ntlmssp_project gss-ntlmsspv < 1.2.01.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.