CVE-2023-25661

Medium

Description

TensorFlow is an Open Source Machine Learning Framework. In versions prior to 2.11.1 a malicious invalid input crashes a tensorflow model (Check Failed) and can be used to trigger a denial of service attack. A proof of concept can be constructed with the `Convolution3DTranspose` function. This Convolution3DTranspose layer is a very common API in modern neural networks. The ML models containing such vulnerable components could be deployed in ML applications or as cloud services. This failure could be potentially used to trigger a denial of service attack on ML cloud services. An attacker must have privilege to provide input to a `Convolution3DTranspose` call. This issue has been patched and users are advised to upgrade to version 2.11.1. There are no known workarounds for this vulnerability.

SeverityMedium
CVSS6.5
Exploit probability—
ProductGoogle Tensorflow
PublishedMar 27, 2023
First seenMar 27, 2023

How to fix

Update
  • google tensorflow2.11.1 or later
  • tensorflow2.11.1 or later
  • tensorflow-cpu2.11.1 or later

Affected products

ProductAffected versionsFixed in
google tensorflowv < 2.11.12.11.1
tensorflowPyPIv < 2.11.12.11.1
tensorflow-cpuPyPIv < 2.11.12.11.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.