CVE-2023-25725

Critical

Description

HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are inadvertently lost in some situations, aka "request smuggling." The HTTP header parsers in HAProxy may accept empty header field names, which could be used to truncate the list of HTTP headers and thus make some headers disappear after being parsed and processed for HTTP/1.0 and HTTP/1.1. For HTTP/2 and HTTP/3, the impact is limited because the headers disappear before being parsed and processed, as if they had not been sent by the client. The fixed versions are 2.7.3, 2.6.9, 2.5.12, 2.4.22, 2.2.29, and 2.0.31.

SeverityCritical
CVSS9.1
Exploit probability—
ProductHaproxy
PublishedFeb 14, 2023
First seenFeb 14, 2023
Weakness typeCWE-444CWE-444

How to fix

Affected products

ProductAffected versionsFixed in
haproxy haproxyv < 2.0.31, 2.1.0 ≤ v < 2.2.29, 2.3.0 ≤ v < 2.4.22, 2.5.0 ≤ v < 2.5.12, 2.6.0 ≤ v < 2.6.9, 2.7.0 ≤ v < 2.7.32.0.31, 2.2.29, 2.4.22, 2.5.12, 2.6.9, 2.7.3
debian debian_linux10.0, 11.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.