CVE-2023-25813

Critical

Description

Sequelize is a Node.js ORM tool. In versions prior to 6.19.1 a SQL injection exploit exists related to replacements. Parameters which are passed through replacements are not properly escaped which can lead to arbitrary SQL injection depending on the specific queries in use. The issue has been fixed in Sequelize 6.19.1. Users are advised to upgrade. Users unable to upgrade should not use the `replacements` and the `where` option in the same query.

SeverityCritical
CVSS10.0
Exploit probability—
ProductSequelize
PublishedFeb 22, 2023
First seenFeb 22, 2023
Weakness typeCWE-89SQL injection

How to fix

Update
  • sequelizejs sequelize6.19.1 or later
  • sequelize6.19.1 or later

Affected products

ProductAffected versionsFixed in
sequelizejs sequelizev < 6.19.16.19.1
sequelizenpmv < 6.19.16.19.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.