CVE-2023-25957

Critical

Description

A vulnerability has been identified in Mendix SAML (Mendix 7 compatible) (All versions >= V1.16.4 < V1.17.3), Mendix SAML (Mendix 8 compatible) (All versions >= V2.2.0 < V2.3.0), Mendix SAML (Mendix 9 latest compatible, New Track) (All versions >= V3.1.9 < V3.3.1), Mendix SAML (Mendix 9 latest compatible, Upgrade Track) (All versions >= V3.1.8 < V3.3.0), Mendix SAML (Mendix 9.6 compatible, New Track) (All versions >= V3.1.9 < V3.2.7), Mendix SAML (Mendix 9.6 compatible, Upgrade Track) (All versions >= V3.1.8 < V3.2.6). The affected versions of the module insufficiently verify the SAML assertions. This could allow unauthenticated remote attackers to bypass authentication and get access to the application. For compatibility reasons, fix versions still contain this issue, but only when the recommended, default configuration option `'Use Encryption'` is disabled.

SeverityCritical
CVSS9.1
Exploit probability—
ProductMendix Saml
PublishedMar 14, 2023
First seenMar 14, 2023
Weakness typeCWE-303CWE-303

How to fix

Update
  • mendix saml1.17.2, 2.2.3, 3.2.5 or later

Affected products

ProductAffected versionsFixed in
mendix saml1.16.4 ≤ v < 1.17.2, 2.2.0 ≤ v < 2.2.3, 3.1.9 ≤ v < 3.2.51.17.2, 2.2.3, 3.2.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.