CVE-2023-26053

Medium

Description

Gradle is a build tool with a focus on build automation and support for multi-language development. This is a collision attack on long IDs (64bits) for PGP keys. Users of dependency verification in Gradle are vulnerable if they use long IDs for PGP keys in a `trusted-key` or `pgp` element in their dependency verification metadata file. The fix is to fail dependency verification if anything but a fingerprint is used in a trust element in dependency verification metadata. The problem is fixed in Gradle 8.0 and above. The problem is also patched in Gradle 6.9.4 and 7.6.1. As a workaround, use only full fingerprint IDs for `trusted-key` or `pgp` element in the metadata is a protection against this issue.

SeverityMedium
CVSS6.6
Exploit probability—
ProductGradle
PublishedMar 2, 2023
First seenMar 2, 2023
Weakness typeCWE-829CWE-829

How to fix

Update
  • gradle gradle6.9.4, 7.6.1 or later

Affected products

ProductAffected versionsFixed in
gradle gradle6.2.0 ≤ v < 6.9.4, 7.0.0 ≤ v < 7.6.16.9.4, 7.6.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-26053 · Gradle · Dark Radar