CVE-2023-27491

Medium

Description

Envoy is an open source edge and service proxy designed for cloud-native applications. Compliant HTTP/1 service should reject malformed request lines. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, There is a possibility that non compliant HTTP/1 service may allow malformed requests, potentially leading to a bypass of security policies. This issue is fixed in versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9.

SeverityMedium
CVSS5.4
Exploit probability—
ProductEnvoy
PublishedApr 4, 2023
First seenApr 4, 2023

How to fix

Update
  • envoyproxy envoy1.22.9, 1.23.6, 1.24.4, 1.25.3 or later

Affected products

ProductAffected versionsFixed in
envoyproxy envoyv < 1.22.9, 1.23.0 ≤ v < 1.23.6, 1.24.0 ≤ v < 1.24.4, 1.25.0 ≤ v < 1.25.31.22.9, 1.23.6, 1.24.4, 1.25.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.