CVE-2023-27580

High

Description

CodeIgniter Shield provides authentication and authorization for the CodeIgniter 4 PHP framework. An improper implementation was found in the password storage process. All hashed passwords stored in Shield v1.0.0-beta.3 or earlier are easier to crack than expected due to the vulnerability. Therefore, they should be removed as soon as possible. If an attacker gets (1) the user's hashed password by Shield, and (2) the hashed password (SHA-384 hash without salt) from somewhere, the attacker may easily crack the user's password. Upgrade to Shield v1.0.0-beta.4 or later to fix this issue. After upgrading, all users’ hashed passwords should be updated (saved to the database). There are no known workarounds.

SeverityHigh
CVSS7.5
Exploit probability—
ProductCodeigniter Shield
PublishedMar 13, 2023
First seenMar 13, 2023
Weakness typeCWE-916CWE-916

How to fix

Update
  • codeigniter4/shield1.0.0-beta.4 or later

Affected products

ProductAffected versionsFixed in
codeigniter shield1.0.0—
codeigniter4/shieldPackagistv < 1.0.0-beta.41.0.0-beta.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.