CVE-2023-27588
Description
Hasura is an open-source product that provides users GraphQL or REST APIs. A path traversal vulnerability has been discovered within Hasura GraphQL Engine prior to versions 1.3.4, 2.55.1, 2.20.1, and 2.21.0-beta1. Projects running on Hasura Cloud were not vulnerable. Self-hosted Hasura Projects with deployments that are publicly exposed and not protected by a WAF or other HTTP protection layer should be upgraded to version 1.3.4, 2.55.1, 2.20.1, or 2.21.0-beta1 to receive a patch.
How to fix
- hasura graphql_engine1.3.4, 2.11.5, 2.20.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| hasura graphql_engine | v < 1.3.4, 2.0.0 ≤ v < 2.11.5, 2.12.0 ≤ v < 2.20.1 | 1.3.4, 2.11.5, 2.20.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.